Updated Information: VeriFone EMV Software

The EMV software for VeriFone Commander and Ruby CI was released in February 2016.  Initially, there were issues with the installation of the new EMV software; however, VeriFone and First Data have worked together to resolve the complications with the software upgrade. 

For those of you who have not made your initial hardware upgrade from the Ruby to either the Commander, Ruby CI, or other type of POS, please contact your POS vendor as soon as possible.  Many vendors are already scheduling 2-3 months out, so the sooner you are able to get on their schedule the better.  If you would like vendor contact information, please contact the office and we will be happy to provide that information to you. 

If you have already upgraded to the Commander or Ruby CI, and in order to prevent EMV-related chargebacks at the POS, please contact your POS vendor as soon as possible to schedule the software upgrade.

Prior to upgrading to the EMV software please keep in mind the following: 

  • Site should have a VeriFone Zone Router installed with the internet connection plugged into the “payment controller” port on the Commander/Ruby CI;
  • VeriFone’s Viper payment server needs to be installed on the indoor pin pad;
  • First Data must be notified in advance of the conversion to set up the new Rapid Connect platform.  You may contact the VeriFone Help Desk to request that this be done or Shelia Cave at (323) 981-2124; and
  • VeriFone must be given 48 hours to activate the EMV software for the Commander/Ruby CI.  This can be done by visiting http://support.verifone.com. Click on the Tech Support Chat or Email banner, and make the following selections from the drop down menu:

Please select the Department/Category for your Chat/Email *

Petro and Convenience 

How would you like to communicate with the VeriFone Tech Support? *

Email    

Select Reason for Contacting Us *

VRSD Upgrade Request 

As always, should you have any questions please feel free to contact the office.